Failure on SlayBot
Incident Report for SlayBot
Postmortem

All times are UTC+3.

Summary

SlayBot was offline globally for a period of about two hours. The cause of the issue was found quickly, but we needed help with our hosting to fix the issue. This issue was caused by our database, SQLite3 which SlayBot uses. Image: https://r.slaybot.xyz/45caf

Timeline

  • 17.21 - We started to upload our new version 2.4.1 files, to SlayBot’s directory
  • 17.24 - We were ready to restart SlayBot using pm2 reload SlayBot
  • 17.28 - A message is sent to our server’s #status channel to let our user know that we are having problems
  • 17.29 - A status page incident is opened to let our users know that we're having problems: https://slaybot.statuspage.io/incidents/647k6gt95qp5
  • 18:19 - We sent message to our hosting to let them know that i need help from them. Image: https://r.slaybot.xyz/26721
  • 18.29 to 18.46 - We were trying to fix the problem with SlayBot hosting’s admin, until i found that i had no enough memory to install the SQLite3 package. Image: https://r.slaybot.xyz/f53dd
  • 18.46 - We got a temporary access to get more memory to fix the whole problem
  • 18.54 - The installation of SQLite3 package was successfully done. Image: https://r.slaybot.xyz/d3e9e
  • 18.56 - SlayBot was restarted and we didnt get any errors!
  • 18.59 - The status page incident is resolved.

Sorry for any inconvenience this caused! We're working around the clock to make sure that SlayBot is reliable and online for everyone, especially as utilization of the platform is at an all time high. Any data was not lost so everything is like nothing happened!

Posted Jul 26, 2020 - 23:25 EEST

Resolved
SlayBot is back online! SlayBot's Hosting helped me to get everything working fine!
Posted Jul 26, 2020 - 18:59 EEST
Update
We have contacted to our hosting if they can help us a little bit.
Posted Jul 26, 2020 - 18:20 EEST
Investigating
We are aware of some problems with SlayBot's new update. We are fixing the problem
Posted Jul 26, 2020 - 17:29 EEST
This incident affected: SlayBot.